use strict;
my $str = '>Some quote <br />
Some simple text<br />
<br>
> another quote with random <b>tags</b> and <a href=>links</a> in it';
my $regex = qr/>([^*]*?)(<br|$)/mp;
my $subst = '<mark class=\\\'quote\\\'>$1</mark>$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";