re = />([^*]*?)(<br|$)/m
str = '>Some quote <br />
Some simple text<br />
<br>
> another quote with random <b>tags</b> and <a href=>links</a> in it'
subst = '<mark class=\\\'quote\\\'>$1</mark>$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result