import Foundation
let pattern = #">([^*]*?)(<br|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
>Some quote <br />
Some simple text<br />
<br>
> another quote with random <b>tags</b> and <a href=>links</a> in it
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<mark class=\'quote\'>$1</mark>$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)