package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)>([^*]*?)(<br|$)`)
var str = `>Some quote <br />
Some simple text<br />
<br>
> another quote with random <b>tags</b> and <a href=>links</a> in it`
var substitution = "<mark class=\'quote\'>$1</mark>$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}