#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(?<!<pre>)\R(?!</pre>)(?=((?!<pre>).)*</pre>)"
Local $sString = "<div>" & @CRLF & _
"test" & @CRLF & _
"test" & @CRLF & _
"test" & @CRLF & _
"</div>" & @CRLF & _
"<pre>" & @CRLF & _
"Line one" & @CRLF & _
"Line two" & @CRLF & _
"Line three" & @CRLF & _
"Line four" & @CRLF & _
"Line five" & @CRLF & _
"Line six" & @CRLF & _
"</pre>"
Local $sSubst = "<br />"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)