import Foundation
let pattern = #"(?<!<pre>)\R(?!</pre>)(?=((?!<pre>).)*</pre>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<div>
test
test
test
</div>
<pre>
Line one
Line two
Line three
Line four
Line five
Line six
</pre>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<br />"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)