use strict;
my $str = '<div>
test
test
test
</div>
<pre>
Line one
Line two
Line three
Line four
Line five
Line six
</pre>';
my $regex = qr~(?<!<pre>)\R(?!</pre>)(?=((?!<pre>).)*</pre>)~sp;
my $subst = '<br />';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";