import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!<pre>)\\R(?!</pre>)(?=((?!<pre>).)*</pre>)";
final String string = "<div>\n"
+ "test\n"
+ "test\n"
+ "test\n"
+ "</div>\n"
+ "<pre>\n"
+ "Line one\n"
+ "Line two\n"
+ "Line three\n"
+ "Line four\n"
+ "Line five\n"
+ "Line six\n"
+ "</pre>";
final String subst = "<br />";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}