# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!<pre>)\R(?!</pre>)(?=((?!<pre>).)*</pre>)"
test_str = ("<div>\n"
"test\n"
"test\n"
"test\n"
"</div>\n"
"<pre>\n"
"Line one\n"
"Line two\n"
"Line three\n"
"Line four\n"
"Line five\n"
"Line six\n"
"</pre>")
subst = "<br />"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.