$re = '~(?<!<pre>)\R(?!</pre>)(?=((?!<pre>).)*</pre>)~s';
$str = '<div>
test
test
test
</div>
<pre>
Line one
Line two
Line three
Line four
Line five
Line six
</pre>';
$subst = "<br />";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;