#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "%(ASA|PIX|FWSM)-\w+-\d+-(\d+):.*"
Local $sString = "Jun 29 00:01:07 29 00: <177>:Jun 29 00:01:25 CEDT: %ASA-session-1-106021: Deny TCP reverse path check from 195.77.230.17 to 95.63.122.200 on interface dmz-Barcelone" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")