using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%(ASA|PIX|FWSM)-\w+-\d+-(\d+):.*";
string input = @"Jun 29 00:01:07 29 00: <177>:Jun 29 00:01:25 CEDT: %ASA-session-1-106021: Deny TCP reverse path check from 195.77.230.17 to 95.63.122.200 on interface dmz-Barcelone
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}