const regex = /%(ASA|PIX|FWSM)-\w+-\d+-(\d+):.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('%(ASA|PIX|FWSM)-\\w+-\\d+-(\\d+):.*', '')
const str = `Jun 29 00:01:07 29 00: <177>:Jun 29 00:01:25 CEDT: %ASA-session-1-106021: Deny TCP reverse path check from 195.77.230.17 to 95.63.122.200 on interface dmz-Barcelone
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}