package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`%(ASA|PIX|FWSM)-\w+-\d+-(\d+):.*`)
var str = `Jun 29 00:01:07 29 00: <177>:Jun 29 00:01:25 CEDT: %ASA-session-1-106021: Deny TCP reverse path check from 195.77.230.17 to 95.63.122.200 on interface dmz-Barcelone
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}