re = /%(ASA|PIX|FWSM)-\w+-\d+-(\d+):.*/
str = 'Jun 29 00:01:07 29 00: <177>:Jun 29 00:01:25 CEDT: %ASA-session-1-106021: Deny TCP reverse path check from 195.77.230.17 to 95.63.122.200 on interface dmz-Barcelone
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end