#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[[\w\s]*id="(\d+)"
Local $sString = " down vote favorite" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"I have a text" & @CRLF & _
"id="44"" & @CRLF & _
"[wow id="44"] bla bla bla [wow id="99"] bla bla bla [wow id="100"] bla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")