re = /\[[\w\s]*id="(\d+)/m
str = ' down vote favorite
I have a text
id="44"
[wow id="44"] bla bla bla [wow id="99"] bla bla bla [wow id="100"] bla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end