$re = '/\[[\w\s]*id="(\d+)/m';
$str = ' down vote favorite
I have a text
id="44"
[wow id="44"] bla bla bla [wow id="99"] bla bla bla [wow id="100"] bla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);