using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[\w\s]*id=""(\d+)";
string input = @" down vote favorite
I have a text
id=""44""
[wow id=""44""] bla bla bla [wow id=""99""] bla bla bla [wow id=""100""] bla";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}