import re
regex = re.compile(r"\[[\w\s]*id=\"(\d+)", flags=re.MULTILINE)
test_str = (" down vote favorite\n"
" \n\n"
"I have a text\n"
"id=\"44\"\n"
"[wow id=\"44\"] bla bla bla [wow id=\"99\"] bla bla bla [wow id=\"100\"] bla")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")