const regex = /\[[\w\s]*id="(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[[\\w\\s]*id="(\\d+)', 'gm')
const str = ` down vote favorite
I have a text
id="44"
[wow id="44"] bla bla bla [wow id="99"] bla bla bla [wow id="100"] bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}