using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(EX: 4)\n";
string input = @"1392714132.861 0 1.2.3.4 TCP_DENIED/407 3922 CONNECT google.com:443 user HIER_NONE/- text/html";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}