// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(EX: 4)\n").unwrap();
let string = "1392714132.861 0 1.2.3.4 TCP_DENIED/407 3922 CONNECT google.com:443 user HIER_NONE/- text/html";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}