import Foundation
let pattern = #"^(EX: 4)\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1392714132.861 0 1.2.3.4 TCP_DENIED/407 3922 CONNECT google.com:443 user HIER_NONE/- text/html"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}