const regex = /^(EX: 4)\n/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(EX: 4)\\n', '')
const str = `1392714132.861 0 1.2.3.4 TCP_DENIED/407 3922 CONNECT google.com:443 user HIER_NONE/- text/html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}