package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(EX: 4)\n`)
var str = `1392714132.861 0 1.2.3.4 TCP_DENIED/407 3922 CONNECT google.com:443 user HIER_NONE/- text/html`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}