re = /^(EX: 4)\n/
str = '1392714132.861 0 1.2.3.4 TCP_DENIED/407 3922 CONNECT google.com:443 user HIER_NONE/- text/html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end