#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "SomeData\n([-+]?[0-9\n]+[0-9,\n]*(?:\.[0-9\n]+)?[ \n]){6,6}SomeData"
Local $sString = "SomeData" & @CRLF & _
"0." & @CRLF & _
"00 0.00 10," & @CRLF & _
"9" & @CRLF & _
"21," & @CRLF & _
"594.89 -9,563,2" & @CRLF & _
"7" & @CRLF & _
"1" & @CRLF & _
"." & @CRLF & _
"0 " & @CRLF & _
"6" & @CRLF & _
"0" & @CRLF & _
"." & @CRLF & _
"0" & @CRLF & _
"0" & @CRLF & _
" " & @CRLF & _
"1" & @CRLF & _
"," & @CRLF & _
"3" & @CRLF & _
"5" & @CRLF & _
"8," & @CRLF & _
"3" & @CRLF & _
"23" & @CRLF & _
".83" & @CRLF & _
"SomeData"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")