$re = '/SomeData\n([-+]?[0-9\n]+[0-9,\n]*(?:\.[0-9\n]+)?[ \n]){6,6}SomeData/';
$str = 'SomeData
0.
00 0.00 10,
9
21,
594.89 -9,563,2
7
1
.
0
6
0
.
0
0
1
,
3
5
8,
3
23
.83
SomeData';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);