using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SomeData\n([-+]?[0-9\n]+[0-9,\n]*(?:\.[0-9\n]+)?[ \n]){6,6}SomeData";
string input = @"SomeData
0.
00 0.00 10,
9
21,
594.89 -9,563,2
7
1
.
0
6
0
.
0
0
1
,
3
5
8,
3
23
.83
SomeData";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}