import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SomeData\\n([-+]?[0-9\\n]+[0-9,\\n]*(?:\\.[0-9\\n]+)?[ \\n]){6,6}SomeData";
final String string = "SomeData\n"
+ "0.\n"
+ "00 0.00 10,\n"
+ "9\n"
+ "21,\n"
+ "594.89 -9,563,2\n"
+ "7\n"
+ "1\n"
+ ".\n"
+ "0 \n"
+ "6\n"
+ "0\n"
+ ".\n"
+ "0\n"
+ "0\n"
+ " \n"
+ "1\n"
+ ",\n"
+ "3\n"
+ "5\n"
+ "8,\n"
+ "3\n"
+ "23\n"
+ ".83\n"
+ "SomeData";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}