# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"SomeData\n([-+]?[0-9\n]+[0-9,\n]*(?:\.[0-9\n]+)?[ \n]){6,6}SomeData"
test_str = ("SomeData\n"
"0.\n"
"00 0.00 10,\n"
"9\n"
"21,\n"
"594.89 -9,563,2\n"
"7\n"
"1\n"
".\n"
"0 \n"
"6\n"
"0\n"
".\n"
"0\n"
"0\n"
" \n"
"1\n"
",\n"
"3\n"
"5\n"
"8,\n"
"3\n"
"23\n"
".83\n"
"SomeData")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.