#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*<amb(?:(?!<\/amb).)+<amb).+$"
Local $sString = "anything <amb id="1">word1</amb> anything <amb id="2">word2</amb> anything // Ok" & @CRLF & _
"" & @CRLF & _
"anything <amb id="1">anything<amb id="2">word2</amb>anything</amb> // KO" & @CRLF & _
"" & @CRLF & _
"anything <amb id="1">word1</amb> sss anything <amb id="1">word1</amb> ddd anything <amb id="1">word1</amb> ddd anything <amb id="1">word1 anything <amb id="1">word1</amb> sss </amb>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")