use strict;
my $str = 'anything <amb id="1">word1</amb> anything <amb id="2">word2</amb> anything // Ok
anything <amb id="1">anything<amb id="2">word2</amb>anything</amb> // KO
anything <amb id="1">word1</amb> sss anything <amb id="1">word1</amb> ddd anything <amb id="1">word1</amb> ddd anything <amb id="1">word1 anything <amb id="1">word1</amb> sss </amb>';
my $regex = qr/^(?!.*<amb(?:(?!<\/amb).)+<amb).+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}