using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*<amb(?:(?!<\/amb).)+<amb).+$";
string input = @"anything <amb id=""1"">word1</amb> anything <amb id=""2"">word2</amb> anything // Ok
anything <amb id=""1"">anything<amb id=""2"">word2</amb>anything</amb> // KO
anything <amb id=""1"">word1</amb> sss anything <amb id=""1"">word1</amb> ddd anything <amb id=""1"">word1</amb> ddd anything <amb id=""1"">word1 anything <amb id=""1"">word1</amb> sss </amb>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}