import re
regex = re.compile(r"^(?!.*<amb(?:(?!<\/amb).)+<amb).+$", flags=re.MULTILINE)
test_str = ("anything <amb id=\"1\">word1</amb> anything <amb id=\"2\">word2</amb> anything // Ok\n\n"
"anything <amb id=\"1\">anything<amb id=\"2\">word2</amb>anything</amb> // KO\n\n"
"anything <amb id=\"1\">word1</amb> sss anything <amb id=\"1\">word1</amb> ddd anything <amb id=\"1\">word1</amb> ddd anything <amb id=\"1\">word1 anything <amb id=\"1\">word1</amb> sss </amb>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")