$re = '/^(?!.*<amb(?:(?!<\/amb).)+<amb).+$/m';
$str = 'anything <amb id="1">word1</amb> anything <amb id="2">word2</amb> anything // Ok
anything <amb id="1">anything<amb id="2">word2</amb>anything</amb> // KO
anything <amb id="1">word1</amb> sss anything <amb id="1">word1</amb> ddd anything <amb id="1">word1</amb> ddd anything <amb id="1">word1 anything <amb id="1">word1</amb> sss </amb>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);