const regex = /^(?!.*<amb(?:(?!<\/amb).)+<amb).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*<amb(?:(?!<\\\/amb).)+<amb).+$', 'gm')
const str = `anything <amb id="1">word1</amb> anything <amb id="2">word2</amb> anything // Ok
anything <amb id="1">anything<amb id="2">word2</amb>anything</amb> // KO
anything <amb id="1">word1</amb> sss anything <amb id="1">word1</amb> ddd anything <amb id="1">word1</amb> ddd anything <amb id="1">word1 anything <amb id="1">word1</amb> sss </amb>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}