using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(st=(\w+))?(&?c=(\w+))?(&t=(\w+))?(&k=(\w+))?( HTTP)";
string substitution = @"\2,\4,\6,\8";
string input = @"st=expand&c=22&t=button&k=fun HTTP
c=22&t=button&k=fun HTTP
st=expand&c=22&t=party&k=fun HTTP
st=expand&c=22&k=fun HTTP
st=expand HTTP
HTTP";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}