import re
regex = re.compile(r"(st=(\w+))?(&?c=(\w+))?(&t=(\w+))?(&k=(\w+))?( HTTP)")
test_str = ("st=expand&c=22&t=button&k=fun HTTP\n"
"c=22&t=button&k=fun HTTP\n"
"st=expand&c=22&t=party&k=fun HTTP\n"
"st=expand&c=22&k=fun HTTP\n"
"st=expand HTTP\n"
" HTTP")
subst = "\\2,\\4,\\6,\\8"
result = regex.sub(subst, test_str)
if result:
print(result)