package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(st=(\w+))?(&?c=(\w+))?(&t=(\w+))?(&k=(\w+))?( HTTP)`)
var str = `st=expand&c=22&t=button&k=fun HTTP
c=22&t=button&k=fun HTTP
st=expand&c=22&t=party&k=fun HTTP
st=expand&c=22&k=fun HTTP
st=expand HTTP
HTTP`
var substitution = "\2,\4,\6,\8"
fmt.Println(re.ReplaceAllString(str, substitution))
}