use strict;
my $str = 'st=expand&c=22&t=button&k=fun HTTP
c=22&t=button&k=fun HTTP
st=expand&c=22&t=party&k=fun HTTP
st=expand&c=22&k=fun HTTP
st=expand HTTP
HTTP';
my $regex = qr/(st=(\w+))?(&?c=(\w+))?(&t=(\w+))?(&k=(\w+))?( HTTP)/p;
my $subst = '\\2,\\4,\\6,\\8';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";