#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\d)(?!.*-.*-)(?!.*-$)(?!-)[a-zA-Z0-9-]{6,20}$"
Local $sString = "abc123" & @CRLF & _
"abc-123" & @CRLF & _
"" & @CRLF & _
"ab12" & @CRLF & _
"-abc123" & @CRLF & _
"abc123-" & @CRLF & _
"ab-12-c3" & @CRLF & _
"123abc" & @CRLF & _
"" & @CRLF & _
"The username can contain English letters, numbers and one hyphen (-)." & @CRLF & _
"" & @CRLF & _
"The username cannot be started with hyphen (-)." & @CRLF & _
"" & @CRLF & _
"The username cannot be finished with hyphen (-)." & @CRLF & _
"" & @CRLF & _
"The username cannot be started with numbers." & @CRLF & _
"" & @CRLF & _
"The username cannot contain more than one hyphen (-)." & @CRLF & _
"" & @CRLF & _
"Minimum is 6 and Maximum 20."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")