re = /^(?!\d)(?!.*-.*-)(?!.*-$)(?!-)[a-zA-Z0-9-]{6,20}$/m
str = 'abc123
abc-123
ab12
-abc123
abc123-
ab-12-c3
123abc
The username can contain English letters, numbers and one hyphen (-).
The username cannot be started with hyphen (-).
The username cannot be finished with hyphen (-).
The username cannot be started with numbers.
The username cannot contain more than one hyphen (-).
Minimum is 6 and Maximum 20.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end