import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\d)(?!.*-.*-)(?!.*-$)(?!-)[a-zA-Z0-9-]{6,20}$";
final String string = "abc123\n"
+ "abc-123\n\n"
+ "ab12\n"
+ "-abc123\n"
+ "abc123-\n"
+ "ab-12-c3\n"
+ "123abc\n\n"
+ "The username can contain English letters, numbers and one hyphen (-).\n\n"
+ "The username cannot be started with hyphen (-).\n\n"
+ "The username cannot be finished with hyphen (-).\n\n"
+ "The username cannot be started with numbers.\n\n"
+ "The username cannot contain more than one hyphen (-).\n\n"
+ "Minimum is 6 and Maximum 20.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}