import re
regex = re.compile(r"^(?!\d)(?!.*-.*-)(?!.*-$)(?!-)[a-zA-Z0-9-]{6,20}$", flags=re.MULTILINE)
test_str = ("abc123\n"
"abc-123\n\n"
"ab12\n"
"-abc123\n"
"abc123-\n"
"ab-12-c3\n"
"123abc\n\n"
"The username can contain English letters, numbers and one hyphen (-).\n\n"
"The username cannot be started with hyphen (-).\n\n"
"The username cannot be finished with hyphen (-).\n\n"
"The username cannot be started with numbers.\n\n"
"The username cannot contain more than one hyphen (-).\n\n"
"Minimum is 6 and Maximum 20.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")