using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\d)(?!.*-.*-)(?!.*-$)(?!-)[a-zA-Z0-9-]{6,20}$";
string input = @"abc123
abc-123
ab12
-abc123
abc123-
ab-12-c3
123abc
The username can contain English letters, numbers and one hyphen (-).
The username cannot be started with hyphen (-).
The username cannot be finished with hyphen (-).
The username cannot be started with numbers.
The username cannot contain more than one hyphen (-).
Minimum is 6 and Maximum 20.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}