#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?i)(?:[2-9AJKQT][hscd]){3}"
Local $sString = "something something Ah6d8c.txt" & @CRLF & _
"something Qd6h7s.txt" & @CRLF & _
"somethingAcKhJssomething.txt" & @CRLF & _
"7h6c8c something.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")