using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:[2-9AJKQT][hscd]){3}";
string input = @"something something Ah6d8c.txt
something Qd6h7s.txt
somethingAcKhJssomething.txt
7h6c8c something.txt";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}