import re
regex = re.compile(r"(?i)(?:[2-9AJKQT][hscd]){3}", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("something something Ah6d8c.txt\n"
"something Qd6h7s.txt\n"
"somethingAcKhJssomething.txt\n"
"7h6c8c something.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")